SharePoint In Action

An attempt to share my day-to-day SharePoint experience

Archive for the tag “SharePoint 2013 Workflow Registeration”

SharePoint 2013 Workflow is not enabled in SharePoint Designer 2013

I had created a Workflow Manager Farm but I was still unable to see the “SharePoint 2013 Workflow” in my SharePoint 2013 Designer.


Here is what I did to make it work:

On my SharePoint server(s) I executed the PowerShell command below to register my workflow:


Register-SPWorkflowService –SPSite –WorkflowHostUri -ScopeName [-PartitionMode] [-AllowOAuthHttp] [-Force]

an example of abow syntax would be:

Register-SPWorkflowService –SPSite "" –WorkflowHostUri "" –AllowOAuthHttp -force

or in my case since it was a dev box(no SSL):

Register-SPWorkflowService –SPSite "" –WorkflowHostUri "<strong>http:</strong>//" –AllowOAuthHttp -force

Please note that the “Workflow Service EndPoint URL” can be found in your SharePoint Server’s IIS Manager:


Please pay a close attention to the protocol your Workflow Service is using. By mistake I put http:// instead of https:// and I was getting error below:

Register-SPWorkflowService : The underlying connection was closed: An unexpected error occurred on a receive.


After running the Powershell command you would need to go to your Central Admin and check the “Workflow Services Application” under “Manage Service Applications”. The Workflow Service Status should read “Workflow is connected”. Once the workflow is connected you should be able to see the “SharePoint 2013 Workflow” in your SharePoint Designer.




Nader Heshmat


Post Navigation